MyProcare Outage
Incident Report for Procare Solutions Service Status
Resolved
An unexpected issue with MyProcare resulted in its unavailability during portions of today. We are pleased to report that MyProcare is back online, and functioning as expected.

Thank you for being a loyal Procare customer.
Posted Jun 03, 2021 - 19:57 MDT
Investigating
An unexpected issue with MyProcare has resulted in its unavailability. We are working closely with our technical teams to bring this service back online as soon as possible.

Thank you for your patience as we work to resolve this issue. We will provide updates as more information becomes available.
Posted Jun 03, 2021 - 19:47 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal).