Payments unavailable
Incident Report for Procare Solutions Service Status
Resolved
An unexpected issue with Payments resulted in its unavailability during portions of today. We are pleased to report that TE is back online, and functioning as expected.

We are going to be following up with our datacenter on this issue.

Thank you for being a loyal Procare customer.
Posted Mar 31, 2021 - 21:55 MDT
Update
We are still working with our technical teams to bring Payments back online as soon as possible.

At this time, our technicians are working with the datacenter technicians to resolved the issue

We apologize for the inconvenience and we appreciate your patience. We will continue to update you while we work to resolve this issue.
Posted Mar 31, 2021 - 21:47 MDT
Identified
We have identified an issue with the payments environment and are quickly working to resolve the situation.
Posted Mar 31, 2021 - 21:06 MDT
This incident affected: Payment Processing (API, TuitionExpress.com, PayNow).