POS Deposit Delay

Incident Report for Procare Solutions Service Status

Resolved

The issue affecting POS deposit display has been resolved. All pending deposits should now be properly reflected in customer accounts. We apologize for any concern this may have caused and thank you for your patience.
Posted Sep 09, 2025 - 12:47 MDT

Investigating

We are aware of reports from some customers indicating that while ACH deposits have been received, corresponding POS deposits are not yet reflected. We are actively monitoring this situation and have engaged our processing partners to confirm there are no delays or interruptions on their end. While we work with them to gather more details, please know that we are tracking this closely and will provide updates as soon as more information is available. Thank you for your patience, and we apologize for any concern this may cause.
Posted Sep 09, 2025 - 11:38 MDT
This incident affected: Payment Processing (PayNow).