Procare Online reported Slowness

Incident Report for Procare Solutions Service Status

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 14:33 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2025 - 08:40 MDT

Investigating

We have received reports that Procare Online and Procare Engagement functionality are currently experiencing system slowness. Our engineers are actively investigating the reason for this issue and working towards a resolution. We will continue to send updates here.
Posted Mar 28, 2025 - 07:24 MDT
This incident affected: Procare Online/Family Engagement (Schools Login, API).