Multiple Systems Impacted
Incident Report for Procare Solutions Service Status
Resolved
While all our systems are fully operational, our team will continue to monitor this issue closely. Thank you for your patience.
Posted Jul 19, 2024 - 11:02 MDT
Monitoring
Services have been restored. Team is continuing to monitor this issue.
Posted Jul 19, 2024 - 06:06 MDT
Identified
We have identified an issue with a third party provider and are working on restoring service as soon as possible.
Posted Jul 19, 2024 - 00:31 MDT
Investigating
We are currently investigating an issue with multiple systems in our environment.

Some customers may be experiencing an issue during this time
Posted Jul 18, 2024 - 23:56 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal, Cloud Database Cluster - Primary, Web Apps) and Payment Processing (API, TuitionExpress.com, PayNow).