Procare Tuition Express
Incident Report for Procare Solutions Service Status
Resolved
The CrowdStrike issue affected our services, but we're pleased to announce that all Procare services have now been fully restored. Our engineering team will continue to closely monitor the situation to ensure stability and address any potential issues promptly.
Posted Jul 19, 2024 - 11:18 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 11:17 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 11:16 MDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 10:59 MDT
Monitoring
The issue affecting batch processing in Tuition Express for our Procare Desktop users has been resolved. Affected customers can now retry processing batch payments. We recommend checking your ledgers to confirm that payments have not been posted and then re-process the batch using Tuition Express > Process Tuition Express.

This issue was caused by the global CrowdStrike outage this morning, and we will continue to monitor the situation closely.
Posted Jul 19, 2024 - 09:45 MDT
Update
We are currently experiencing a third-party network outage affecting batch processing in Tuition Express for our Procare Desktop users. Our team is working to restore this function as soon as possible. If you are a Procare Desktop user, please refrain from processing any new payments until the issue is resolved.
Posted Jul 19, 2024 - 09:06 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 08:39 MDT
Identified
We are currently experiencing reported issues with payment processing in Tuition Express. Our engineering team is actively working to resolve the problem. We will provide updates as soon as they become available. We apologize for any inconvenience and appreciate your patience.
Posted Jul 19, 2024 - 08:25 MDT
This incident affected: Payment Processing (API, TuitionExpress.com, PayNow).