Mobile Payment Issue for iOS Users
Incident Report for Procare Solutions Service Status
Resolved
The "Pay Now" button issue on iOS has been fixed in version 5.8.2 of our mobile app. Please update to version 5.8.2 via the App Store. If issues persist after updating, contact our support team.

We apologize for any inconvenience caused.
Posted Jul 23, 2024 - 07:05 MDT
Investigating
We are investigating reports of iOS users unable to use the “Pay Now" button on the home screen in our mobile app. Our team is actively working on a resolution.

We will update this status as new information becomes available.

For urgent payments, users can submit payments on the mobile app through the Hamburger Menu > Make Payment. Or on the web portal at https://schools.procareconnect.com/login.

We apologize for any inconvenience and appreciate your patience.
Posted Jul 18, 2024 - 10:18 MDT
This incident affected: Procare Online/Family Engagement (API).