Payments issues

Incident Report for Procare Solutions Service Status

Resolved

This incident has been resolved, and all payments are now processing successfully. If you continue to experience any issues, please contact our Support team for further assistance
Posted May 06, 2025 - 13:09 MDT

Update

We are continuing to work on a fix for this issue.
Posted May 06, 2025 - 07:00 MDT

Identified

Some Procare Desktop users are currently experiencing errors when attempting to process point-of-sale transactions. Our technical team is actively working to address this issue. We will provide another update when more information becomes available. We apologize for any inconvenience this may cause to your operations. Thank you for your patience.
Posted May 06, 2025 - 06:15 MDT
This incident affected: Payment Processing (API, TuitionExpress.com, PayNow).