The slowness issues affecting some users on the Procare Online web and mobile applications has been resolved. All systems are now operating normally. Please contact support if you continue to experience any issues.
Posted May 30, 2025 - 09:13 MDT
Monitoring
We have implemented a fix for the slowness issues that were affecting some users on the Procare Online web and mobile applications. Our engineering team is now monitoring system performance to ensure stability. We are seeing positive improvements across all systems and will continue monitoring system performance to confirm the issue is fully resolved. Thank you for your patience during this incident.
Posted May 30, 2025 - 08:29 MDT
Investigating
We are currently investigating reports of slowness affecting some users on the Procare Online web and mobile applications. Our engineering team is aware and actively working to identify the root cause. We will provide an update as soon as more information becomes available. Thank you for your patience, and we apologize for any inconvenience this may cause.
Posted May 30, 2025 - 06:54 MDT
This incident affected: Procare Online/Family Engagement (Schools Login, API).