The performance issues affecting Procare Online have been fully resolved and all data remains secure. During this brief service interruption, some time entries from Procare Desktop may not have synced completely, which would appear as red cloud indicators in Procare Engagement. We recommend reviewing today's (8/21) time entries to confirm they synced properly. If any entries need to be resynced, delete and re-enter them in Desktop, wait a few minutes, then refresh Procare Engagement to verify they appear. To avoid conflicts, please don't edit the same child's time in both systems simultaneously. For assistance, contact our support team at 1-800-964-1729. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted Aug 21, 2025 - 18:35 MDT
Monitoring
We have implemented a solution for the performance issues affecting Procare Online and are closely monitoring to confirm stability. Users should begin to see improved responsiveness and connection reliability. The Daily Activity Feed has been re-enabled and Procare Engagement syncs have resumed. Please allow a brief period for the system to process backlogged activities and syncs. We will continue to monitor and provide updates as needed.
Posted Aug 21, 2025 - 10:03 MDT
Identified
Our engineering team is actively working toward a full resolution. To support recovery, we have temporarily paused the Daily Activity feed. Daily Activities submitted during this period will be retained, but will not appear in the feed until processing resumes. We will restore the feed as soon as performance stabilizes and will share further updates as progress is made.
Posted Aug 21, 2025 - 08:27 MDT
Investigating
We are currently investigating reports of system slowness and connection errors affecting some Procare Online users. Our team is actively working to identify the root cause and restore full performance. We appreciate your patience and will provide updates as more information becomes available.
Posted Aug 21, 2025 - 06:44 MDT
This incident affected: Procare Online/Family Engagement (Schools Login, API).