Procare Online Degraded Performance

Incident Report for Procare Solutions Service Status

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 08:25 MDT

Monitoring

The issues impacting Procare Online this morning have been mitigated.

All services are operational, and we will continue to monitor to ensure full resolution.
Posted Aug 27, 2025 - 07:12 MDT

Investigating

We are currently aware of issues affecting Procare Online.

Some users may experience slowness or encounter server error messages. Our team is actively investigating and working as quickly as possible to resolve the issue. We appreciate your patience and will share updates as they become available.
Posted Aug 27, 2025 - 06:26 MDT
This incident affected: Procare Online/Family Engagement (Schools Login, API).