Procare Online Slowness
Incident Report for Procare Solutions Service Status
Resolved
This incident has been resolved.
Posted May 23, 2022 - 12:17 MDT
Identified
We have received reports that customers are experiencing decreased performance in Procare Online. Our engineers are actively investigating the reason for this issue and working towards a resolution. We will continue to update you as we have more information.
Posted May 23, 2022 - 10:03 MDT
This incident affected: Procare Online/Parent Engagement (Schools Login, API).