The issue affecting the ability to save payment methods in Procare Online, Procare Desktop, and SchoolCare Works has been resolved. All systems are now functioning as expected.
We appreciate your patience while our team worked to address this.
Posted Jul 21, 2025 - 08:28 MDT
Update
We’re aware of an issue affecting the ability to save payment methods in Procare Online, Procare Desktop, and SchoolCare Works. Our team is actively investigating and working to restore full functionality. We’ll provide updates as soon as additional information becomes available.
Posted Jul 21, 2025 - 07:48 MDT
Investigating
We’re aware of an issue affecting the ability to save payment methods in Procare Online. Our team is actively investigating and working to restore full functionality. We’ll provide updates as soon as additional information becomes available.
Posted Jul 21, 2025 - 07:28 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal), SchoolCare Works/DayCare Works (API), and Procare Online/Family Engagement (API).