Procare Online Slowness
Incident Report for Procare Solutions Service Status
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted May 24, 2022 - 10:19 MDT
Monitoring
We believe the immediate issue relating to system performance has been resolved and we will continue to monitor and provide updates as needed.
Posted May 23, 2022 - 17:50 MDT
Identified
We have received reports that customers are experiencing decreased performance in Procare Online. Our engineers are actively investigating the reason for this issue and working towards a resolution. We will continue to update you as we have more information.
Posted May 23, 2022 - 12:39 MDT
This incident affected: Procare Online/Parent Engagement (Schools Login, API).