[Intermittent] Procare Professional Development is Unreachable

Incident Report for Procare Solutions Service Status

Resolved

Procare Professional Development is now fully accessible. You can visit the following websites to continue your learning journey:
https://procareprofessionaldevelopment.com/
https://childpluscontinuingeducation.com/

If you continue to experience any issues accessing these websites, please contact Procare Support for further assistance.
Posted Jul 21, 2025 - 16:17 MDT

Identified

We have identified that Procare Professional Development is intermittently unreachable due to ongoing performance issues with a third-party provider.

Our team is actively working with the third-party provider to resolve this issue. In the meantime, if you are experiencing access issues, please try the following steps to help restore access:
1. Ensure that "www" is included in the URL.
2. Clear your browser cache and cookies.
3. Try using a different browser.
4. Use an incognito window.

We apologize for the inconvenience and appreciate your patience and understanding as we work towards a resolution.

Impacted Websites:
https://procareprofessionaldevelopment.com/
https://childpluscontinuingeducation.com/

Access will be restored as soon as the issue is resolved.
Posted Jul 21, 2025 - 09:37 MDT
This incident affected: Procare Professional Development (Procare Professional Development, ChildPlus Continuing Education).