Desktop to Engagement Functionality Sync Delays

Incident Report for Procare Solutions Service Status

Resolved

The sync issue between Procare Desktop and Engagement Functionality has been resolved. Normal synchronization has resumed, and we are now processing any backlogged data. It may take some time for all pending changes to fully sync across both platforms. No data has been lost during this incident, and we will continue to monitor the situation to ensure stable performance. We apologize for any inconvenience this may have caused.
Posted Sep 08, 2025 - 09:01 MDT

Investigating

We are currently investigating a sync issue affecting data synchronization between Procare Desktop and Engagement Functionality. Changes made in Procare Desktop, such as adding new families or updating existing family information, may be delayed or not appear immediately in Engagement Functionality. This issue does not impact attendance sync. Both platforms remain fully operational for daily use, and any data entered will be preserved and sync automatically once resolved. Our team is actively working to identify and fix this issue as quickly as possible. We'll continue to provide updates as more information becomes available.
Posted Sep 08, 2025 - 07:08 MDT
This incident affected: Procare Desktop (Web Apps).