Procare Online Degraded Performance
Incident Report for Procare Solutions Service Status
Resolved
QR Code functionality and mobile app payments are now working as expected. Please note that the QR Code will need to be refreshed before use.
Posted Feb 04, 2025 - 07:58 MST
Investigating
We are currently experiencing degraded performance, affecting QR Code functionality and the payment screen on the mobile app.

After scanning a QR Code, some users may see a blank screen. Additionally, the payment screen may appear blank for some users in the mobile app.

Our team is actively investigating the issue and working to resolve it as quickly as possible. We appreciate your patience and will provide updates as more information becomes available.
Posted Feb 04, 2025 - 07:37 MST