We've implemented measures that have successfully resolved the issue impacting Procare Online and the Family Engagement App. We sincerely apologize for any inconvenience this may have caused. If you continue to experience issues, please reach out to our Customer Support team.
Posted May 09, 2025 - 12:12 MDT
Monitoring
We’ve implemented measures to improve the user experience, and both the mobile app and Procare Online should begin functioning as expected shortly. Users may already be noticing improvements. Our engineers will continue to monitor performance.
Posted May 09, 2025 - 09:22 MDT
Update
We’ve implemented measures to improve the user experience, and both the mobile app and Procare Online should begin functioning as expected shortly. Users may already be noticing improvements. Our engineers will continue to monitor performance.
Posted May 09, 2025 - 07:06 MDT
Investigating
We are currently investigating an issue impacting Procare Online and the mobile app. Some users are experiencing problems launching the app or logging in. Others are reporting slowness when navigating within Procare Online.
Our engineering team is actively working to identify the cause and implement a fix. We will provide updates as more information becomes available.
Posted May 09, 2025 - 05:52 MDT
This incident affected: Procare Online/Family Engagement (Schools Login, API).