Our Phone Provider is Expeiencing an issue - Please reach out via Email or Chat
Incident Report for Procare Solutions Service Status
Resolved
Our Phone Provider has had full functionality restored. You can once again contact support through phones or continue to contact us through email and chat. Thank you for your patience.
Posted Mar 15, 2024 - 07:53 MDT
Investigating
Our phone provider had identified an issue and is working towards a resolution. If you are unable to reach us by phone please reach out to our support team via email (support@procaresoftware.com). Support can also be reached through the Procare child care mobile app. When logged into your staff account on the mobile app, navigate to the menu and select Help & Support > Contact Customer Service to start a conversation with Procare support.
Posted Mar 15, 2024 - 07:21 MDT
This incident affected: Procare Desktop (MyProcare Parent Portal, Cloud Licensing Server, Cloud Database Cluster - Primary, Web Apps), Procare Online/Family Engagement (Schools Login, API), SchoolCare Works/DayCare Works (API, SchoolCareWorks Main Site, DayCareWorks Main Site), and Payment Processing (API, TuitionExpress.com, PayNow).